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Document Notation

Left-mouse-button 
a.k.a. primary 
button.  A click on 
this button is referred 
to as a left-click.

press

release

slide

Bold text refers to 
menu lines on 
figures on the page.

Tips and techniques 
are generally located 
on the lower left of 
the page.

Mouse button clicks and 
snaps are indicated by an 
arrow pointer.

Press-slide-release 
a.k.a. dragging 
actions are indicated 
by a pair of arrow 
pointers.

Right-mouse- 
button a.k.a. 
secondary button.  
A click on this 
button is referred to 
as a right-click.

Menu hierarchies are shown as Parent > 
Child (like Edit > Align > Tops).

This is the notation style used throughout this document.

When a clicked position is 
adjusted by a snap the 
adjusted position is indicated 
by a red circle.

A press of the enter key a.k.a. 
carriage return is indicated by 
a button icon. enter

Encompass > Editing > Tools > Document Notation
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Features and Primitives

Point Must have only one vertex.  A point has no length or area.

Line Must have at least two vertexes.  A line has a length, but no area.  Lines may be closed (meaning 
it may look like a polygon).  A segment is the portion of a line between two vertexes.

Polygon Must have a minimum of three vertexes if there is at least one curved segment.  If there are no 
curved segments, there must be at least four vertexes.  The first and last vertex on a polygon are 
always coincident.  A circle is a three vertex polygon with two segments that are each half circles.

Text Must have only one vertex which is located at the text justification point.  One text primitive may 
contain multiple lines of text.  

Annotation Like text, but must be in a feature that also has at least one point, line, polygon, or text primitive. 

Data Annotation Like annotation but refers to one or more database fields for text content.

Leader Like line, but must be in a feature that also has at least one point, line, polygon, or text primitive.

Annotation, data annotation, and leaders are only displayed when the layer’s Display Annotation flag is set.

A feature is a graphic digital representation of a real world entity.  Examples of features are manholes, water mains, 
Assessor’s parcels, doors, room areas, street centerlines, and street name labels.  Like features are grouped into 
feature classes.  Features in the same feature class have the same attributes, edit methods, and edit authorities.

A primitive is a single graphic element.  Features may contain one or more primitives.

Features fall into one of five feature types: (1) point, (2), line, (3) polygon, (4) text, or (5) composite.  A composite type 
may contain any combination of primitive types.  All feature types may contain annotation and leaders. 

Primitive Types

Encompass > Editing > Tools > Features and Primitives

A feature is stored as a single record in a table in an relational database 
(like Microsoft’s Access or SqlServer).  This record may contain attribute 
columns as well as the columns that contain the feature geometry



Page 5

GIS Feature Data Hierarchy
Catalog:  servers containing 
databases for multiple 
jurisdictions  (may be distributed 
over a network).

Encompass > Editing > Tools > GIS Feature Data Hierarchy

Civic 
Center

Feature Dictionary:  a set of folders 
containing database files for a single 
jurisdiction  (may be distributed over 
a network).  Contains multiple groups.

Group:  a set of tables in a 
database with a common owner 
and prefix.  Contains multiple 
feature classes

Feature Class:  a table in a database 
containing feature records.

Feature:  one record in a table containing 
attribute fields and a geometry field.

Graphic Primitive:  a single graphic element.  
The constituent parts of a feature geometry.

Feature Geometry:  BLOB from the 
geometry field in the feature record. 
Contains one or more primitives.

Civic 
Center

Layer:  a Feature 
Class with styles 
and filters applied 
for viewing.
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Mouse Interaction
Press-Slide-Release
This is a simple action where the entire edit operation is accomplished with one mouse down and one 
mouse up action with the pointer being moved in between.  This provides for quick and easy user 
interaction but not much precision.  The term “dragging” is used synonymously with press-slide-release.
Multiple Click Positions
The multi-click approach uses a sequence of mouse clicks, one for every position needed by the edit 
method.  A click is a mouse down and mouse up action in a short amount of time without moving the 
pointer in between.  This approach allows for precise input techniques like the use of snapping and 
relative position entry.

mouse  
down 

(press)

mouse 
up 

(release)
slide

1st 

click

2nd 

clickmove

Right-Mouse-Button Click
The right-mouse-button may cause either a menu or a dialog (a.k.a. window) to pop up depending on pointer location 
and context.
The toolbar dialogs are used primarily to set properties for edit operations (like fillet radius or graduation tick length) 
and secondarily to provide extended functionality for more advanced users (like clearing the selected feature list).  
Tool dialogs are sensitive to the tool over which the pointer is located.
The popup menu is used either to (1) fine-tune mouse positions (like snapping to a line or setting a relative position) 
when the user is in the middle of executing an operation, (2) take an action (like ending the input of a line feature), (3) 
set properties for the edit tool, or (4) invoke a new (commonly used) edit tool (like delete or move).  The popup menu 
is sensitive to the current edit tool as well as where the user is in the input sequence.  For example, the "Close" 
option is only offered for the "add line" tool and only if the user has entered more than two vertices for the line under 
construction.

Repeating Snaps
Depending on the mouse hardware and driver software, the third button may be programmed to repeat the most 
recent snap type.  This is useful for input sequences that use the same snap repeatedly.

Encompass > Editing > Tools > Mouse Interaction
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Precision Input
There are several methods for precisely defining vertex positions and line geometries: 

• new or existing vertexes may be added or moved to a position on an existing 
geometry using a variety of snapping techniques (like Nearest Point) using the 
tool popup menu,

• vertexes may be added or moved by defining their position relative to the last 
clicked position using the Adjust Position dialog,

• vertexes may be added or moved to an exact coordinate position using either 
State Plane coordinates or Latitude and Longitude using the Adjust Position 
dialog, and

• new line geometries may be constructed (a.k.a. “traversed”) using a COGO 
(Coordinate Geometry) entry method through the Traverse dialog.

Encompass > Editing > Tools > Precision Input
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Snapping

No Click Adjustment uses the last clicked position without making any 
adjustments.

Nearest Point snaps to the nearest point or vertex on a line or polygon 
boundary.

Nearest Line snaps to the nearest line or polygon boundary.

Nearest Text snaps to the nearest of the nine justification points on a text 
feature.

Nearest Center Point snaps to the center of an arc segment or circle.

Nearest Mid Point snaps to the mid-point of a line or arc segment.

Nearest End Point snaps to the end point of a line or arc segment that is 
closest to the clicked point.

Nearest Intersection snaps to the point where two lines or arcs cross but 
may not have vertexes at the intersection point..

Nearest Tangent Point snaps to the tangent point between a straight line 
and an arc or circle, or between two arcs or circles. 

Perpendicular To Line snaps to the position on a line or arc segment 
that creates a right angle from the previously entered vertex.  This snap 
type is only available when drawing lines after the first vertex is defined.

Center of Polygon Mass snaps to the center of mass of a polygon (a 
weighted average of the polygon vertexes).

Launch the snap menu with 
a right-mouse-button click 
on the map.

Snap tolerance is 6 pixels.

For snapping on a grid see 
the Grid Tool.

For snapping priority see 
the Select Tool.

Each geometry tool may 
add tool-specific menu 
items to the bottom of the 
popup menu.  

Snapping adjusts the clicked position precisely to an existing feature.  The exact 
position on the feature is determined by the snap method used:  

ABC

Encompass > Editing > Tools > Snapping
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Adjust Position
Adjust Position… displays the Position Dialog for adjusting the position relative to 
the previously entered position or to an exact coordinate.

Use Absolute to enter an X and Y in State Plane coordinates.  Check 
Use Northings and Eastings to alter the coordinate labels to Easting 
and Northing.  

Use Lat/Long (deg-min-sec) to enter Latitude and Longitude in a 
degrees, minutes and decimal seconds format.  Use Lat/Long 
(decimal deg) to enter Latitude and Longitude in a decimal degree 
format.  

Encompass > Editing > Tools > Adjust Position

Use Relative to enter a position that is offset from the previously 
entered position by the values entered in X and Y. Positive X and Y 
values adjust the position to the right and up, negative values adjust 
the position to the left and down.

Use Bearing & Distance to enter an Angle in degrees, minutes, and 
seconds, and a Distance to define a vector whose end is relative to 
the previously entered position.  An angle of N 0° 0' 0" E or W is up, S 
0° 0' 0" E or W is down, N 90° 0' 0" E or S 90° 0' 0" E is to the right, 
and N 90° 0' 0" W or S 90° 0' 0" W is to the left. 
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Networks – Links and Nodes
A link/node network is a model of a system through which there is flow.  
Link: a linear conveyance that connects two nodes.  Examples of links are main, lateral and service pipes, 

ductbeams, electric distribution conductors, and road centerlines.
Node: a point structure that is connected at the end of at least one link.  Examples of nodes are manholes, 

valves, catch basins, vaults, switches, and road intersections. Network connectivity may be 
interrupted or redirected at a node.  

Point Tap: a connection from one link end to any position along a second link that is not at the end.  Examples 
of point taps are wye and tee fittings that connect laterals to a main pipe, and gas taps that connect 
a service line to a main. 

flow direction
link

nodepoint tap

Network Rules
• Nodes must be at link ends.
• A link must connect to at least one node at one of its ends 

and at most to two nodes, one at each end.
• A node must have at least one link and may have any 

number of links connected to it.
• A point tap must lie along the link that is being tapped.  The 

point tap may not be at the link end. 
• Links are drawn in the direction of flow.  In a pressure 

system, this is the direction of normal operation.  For road 
centerlines this is in the direction of ascending addresses.

• Links should not pass through nodes.
• There should never be more than one node or point tap at 

the same position. 

Encompass > Editing > Tools > Networks – Links and Nodes
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Setting An Edit Tool

The Editing Toolbar is the primary means for setting the tools that are used to edit features.  The Editing Toolbar is 
displayed when the Sketch tool on the Map Toolbar is clicked and hidden when the Pan, Zoom In, Zoom Out, 
Measure, or Identify tools on the Map Toolbar are clicked.

Editing tools are enabled based on the spatial feature type of the current layer and the rules defined for the feature 
class.  For example, a feature class that only allows polygons may only enable the tools for adding new features 
that generate polygons.

Some menu entries on the Edit menu and on the tool popup menus 
also set tools.  In the case of the Edit menu, the tool setting is implicit.  
For example, aligning the selected features starts the Move tool.  In 
the case of the popup menus, the tools that may be set are listed at 
the bottom of the menu if the current edit is in a state that allows the 
tool be switched.

Encompass > Editing > Tools > Setting An Edit Tool

Changing tools generally does not clear 
the selected feature list so multiple edits 
may be run sequentially on the same set 
of features.  The exceptions to this rule 
are the tools that add new features. 

Feature Edit Tool
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Use the Select tool to choose one or more features to make them available for 
subsequent edit operations.  

Clear Selected Features releases the selected features.  This action is only enabled 
when there are one or more currently selected features.

Select By Click or Drag Box sets the selection mode to select features using clicked 
positions or dragged rectangles.

Select By Polygon sets the selection mode to select features using a polygon.  The 
first click on the map starts the polygon input.  Use either the End Input menu, the 
enter key            , or double-click to end the polygon construction and select features.

The current mode is checked on the popup menu and the tool button is changed to     
for the click or drag mode or      for the polygon mode.

When using the dragged box or polygon, features from the current layer that are inside 
or overlapping the box or polygon boundary are selected.  

The feature select priority is (1) the current layer, (2) all other layers based on the 
current layer’s feature class in reverse display order, and (3) all other layers in reverse 
display order.  If layers are set to non-selectable or are outside their display threshold, 
they are not tested for selectable. 

The Select Tool

Hold the shift key down while 
selecting to keep the 
currently selected features in 
the list.

Features are selected first 
from the current layer.

Use a snap instead of a left- 
click to pick up only one 
feature when there are 
several in close proximity.

The drag box may be used 
on a rotated map.

Encompass > Editing > Tools > Select

Click to select features 
at a single position.

Drag a box to select 
multiple features.

Draw a polygon to select multiple 
features in an irregular area.

enter
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The Attribute Tool
The Attribute column displays the name and the Value column displays the 
value of each attribute for the selected feature.  If more than one feature is 
selected and the values for an attribute are not identical, the Value column 
displays “(mixed)” for that row. 

Hold the mouse over any cell to see the 
full attribute name and value displayed in 
a tool tip.

Dropdown lists may not be in alphabetical 
order.  Typing into the dropdown cell 
when the list is displayed jumps to the 
closed value in the list.

Set default values for attributes when 
adding several similar features.

Encompass > Editing > Tools > Attribute

Mandatory attributes (attributes that must have a value in order for 
the feature to be valid) are indicated by bold Attribute names.  A 
grayed background in the Value column indicates that the attribute 
value is not editable.

Mandatory value 
Non-editable value

When editing attribute values, the current cell appears recessed and is either 
a text entry box or, if there is a set of legal values defined for the attribute, a 
dropdown list.  

Validation for an entered value is performed either when the enter key            
is pressed, when leaving the cell by using the arrow keys or clicking on 
another cell, or when closing the Attribute Edit window. 

To copy an attribute name, value, or all the contents of the Attribute Edit 
window to the Windows clipboard, use Copy Attribute ‘abc’ , Copy Value 
‘abc’, or Copy All.

Use Current Value As Default sets the default value for the clicked row so 
that subsequent new features have that default value automatically applied.  
Unset Default Value For ‘abc’ removes the default value for the clicked row.

Click on a A Value cell with and arrow                    to expand the window to 
include related feature data.  See The Attribute Tool - Related Features. 

enter
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The Attribute Tool - Related Features

Click on an arrow in the Value column to expand the window to include related feature data. 

The Add button is enabled only if the relationship allows it.  Clicking the Add button either 
adds a new row to be filled out at the bottom of the grid or displays another grid from which a 
feature to be related may be picked. 

The attribute window may 
only be expanded to include 
related feature data when a 
single feature is selected.

Note the arrow in the Value 
column is reversed for the 
expanded related features.  
Clicking on the reversed 
arrow collapses the window.

Use the arrow keys to move 
the focus around the grid.

Use the escape key or click 
on the lightened part of the 
window to close the add 
feature list.

Encompass > Editing > Tools > Attribute – Related Features

The Remove button is enabled only if the current row in the grid may be removed.

The Popup menu has options for copying a single value, a single row, a single column, or 
all of the grid to the Windows clipboard.
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When editing, clicking on the 
document in the Related 
Documents window does not 
display the document.  When 
using the Identify tool, 
clicking on a document in the 
list does display it.

Encompass > Editing > Tools > Attribute – Related Documents

The Attribute Tool - Related Documents
To relate documents to specific features, first use the Select tool to 
select one or more features, then start the Attribute tool to display 
the Edit Attribute window.  Documents may then be associated to 
the selected feature in either of two ways:

• documents may then be dragged from any Window’s Explorer 
window and dropped onto the Edit Attribute window, or

• click on the Related Documents row of the grid                          
to the display the Related Documents window and click the Add 
File button to browse to a file to associate. 

To remove existing relationships between documents and features, 
click on the Related Documents row of the grid to the display the 
Related Documents window, select the document, and either click 
the Remove button or click Remove Document Association from 
the popup menu.  This action does not delete the document, it just 
removes the relationship between the selected features and the 
document.

Web pages may also be associated with features through the Related 
Documents window.  There is no drag-and-drop method for URL 
associations.  Use the Add URL button to display  
the Associate URL window.  Type or paste the 
web page URL into the text box and click OK to 
define the relationship.  Use the Remove button 
to remove the URL association. 

Use Display Document on the popup menu to display the document.  
Clicking on the document while editing just selects it for an edit operation.
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The Style Tool

The Style window is used by Encompass applications 
to edit the feature styles where a feature class allows 
feature-by-feature style edits as well as for modifying 
how features are displayed in layers on the map.

Use the Style tool to set the style for new features or 
to change the style of the selected features.

Tabs on the Style Dialog are enabled based on the 
feature type.

Annotation and Leader tabs are only enabled if the 
feature class supports embedded annotation.

Most managed feature 
classes do not allow feature- 
by-feature style edits.  
Personal feature classes 
typically do allow feature 
style edits.  

Encompass > Editing > Tools > Style

When used for modifying map display styles, the Style 
window includes two boxes in the upper left corner.  
When Override Feature’s Style is checked, the 
display styles of the features for that layer may be 
altered.  Changing a style in this context does not 
cause an edit to the features in the layer.  

To display the Style window for map content 
alterations, click on the layer’s icon on the legend in 
the Map Contents window. 
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The Style Tool - Line

To set the line pattern select from the Pattern 
dropdown list. 

Use Width to set the line width in map units (like 
feet).  A width of zero (0) produces a one-pixel 
wide hairline.  The line width must be zero or 
greater than zero.

The end marks for line patterns such as arrow 
heads grow proportionally in size to the width of 
the line. 

Some line style examples:

Use the (invisible) pattern to hide 
the line without deleting it.

Entering a line width of -1 sets the 
pattern to invisible and the line 
width to 0.

A line with a width of zero displays 
thinner on a printer than on the 
screen because of the one-pixel 
width.

Encompass > Editing > Tools > Style > Line

Solid

Dash

Dot

Dash-Dot

Dash-Dot-Dot

Arrow

Ductbeam

Fence

Vertex
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The Style Tool - Polygon

Set the pattern fill height to  
the map scale (e.g. if the 
map scale is 1” = 200’, set 
the fill height to 200).

20% background color 
makes a pleasant looking 
pastel fill color.

Encompass > Editing > Tools > Style > Polygon

Use Outline Color to set the polygon boundary 
color and Fill Color to set the polygon area color.  
Fill Color is ignored if the Fill Style is transparent 
or multi-colored.

To set the polygon outline pattern select from the 
Line Pattern dropdown list.  Use “(invisible)” to 
display the polygon without an outline (only the filled 
area displays).

Use Line Width to set the polygon outline line width 
in map units (like feet).  A width of zero (0) produces 
a one-pixel wide hairline.  A width of -1 makes the 
outline invisible regardless of the line pattern.  
Otherwise, the line width must be zero or greater.

To set the polygon fill pattern select from the Fill 
Style dropdown list.  Use “Transparent” to display 
only the polygon outline.

Some fill styles may be sized.  In these cases, use 
Fill Height to set the vertical fixed interval used for 
the repetition of the fill pattern.

If the fill style is not sizable, the fill color may be 
adjusted to include a percentage of the map 
background color using the slider bar. 

Solid

Solid w/20% Fill

Vertical Line

Diagonal Cross
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The Style Tool - Symbol

Use Symbol Source to set the list of available 
symbols shown in the Symbol dropdown list.  Select 
GIS to select a symbol that is drawn using the 
Symbol Color.  Select File to select a symbol that is 
an icon (.ico), bitmap (.bmp), or Windows Meta File 
(.wmf).

Bitmap file symbols always mask graphics over the 
rectangular extent of the bitmap.  GIS symbols and 
icon and Windows Meta Files allow transparency 
where there are no symbol graphics.

File symbols do not show 
point rotation (that always 
draw as if the point rotation is 
zero).

Click on the Symbol control 
and use the up and down 
arrow keys to step through 
the symbol list and view the 
symbols in the Sample box.

Encompass > Editing > Tools > Style > Symbol

(default)

Icon, Star

Luminaire

Knox Box

Gate Valve

Fire Extinguisher

Use Height to set the 
symbol height in map units 
(like feet).  Height must be 
greater than zero.
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The Style Tool - Text

Use Font to set the Windows font.  Check the Bold 
and/or Italic boxes to alter the selected font’s 
properties.

Use Height to set the text height in map units (like 
feet).  Height must be greater than zero.

Encompass > Editing > Tools > Style > Text

Arial

Arial Italic

Arial Bold

Arial Italic Bold

Courier New

Times New Roman

Book Antiqua

Wingdings

Font height includes space 
above and below the text, so 
a capital letter height will be 
approximately 2/3 the height 
of the style.

ABC abc Font Height (includes space for super and sub script text) 2/3 Font Height (actual capital letter height)
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The Style Tool - Annotation and Leader

The Annotation and Leader Tabs are enabled when 
the feature class being edited supports embedded 
annotation.  

The Annotation style setting behaves identically to 
the Text style and Leader behaves identically to Line 
style.

Encompass > Editing > Tools > Style > Annotation and Leader

Use Annotation to set the 
value display of a luggage 
tag.
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The Ungroup Tool

The Ungroup tool is enabled when a single feature is selected that is either a standard feature or a sketch feature that 
contains two or more primitives.  

Ungrouping a standard feature allows parts of it (like annotation or leader lines) to be edited independently.  When a 
standard feature is ungrouped, the first primitive in the feature is automatically selected.  Use the Select tool to select a 
different primitive. Only one primitive at a time may be selected and edited on an ungrouped standard feature. 

When a sketch feature is ungrouped, it is split into multiple features, each containing one primitive per feature.  
Attribute values on the new single-primitive features are copied from the original multi-primitive feature.  All of the 
single-primitive features remain selected after the ungroup operation is performed. 

Use Nearest Text snapping 
to select annotation 
primitives when ungrouped. 

When a standard feature is 
ungrouped, it must be 
regrouped before another 
feature may be selected.

Encompass > Editing > Tools > Ungroup

A selected standard feature (a gas main pipe with annotation).

3” ABS 9-66  ABM 577

3” ABS  9-66  ABM 577

3” ABS  9-66  ABM 577
An ungrouped standard feature with the line primitive selected.

An ungrouped standard feature with an annotation primitive selected.

A selected sketch multi-primitive feature (a nested polygon  
a.k.a. a polygon with a hole in it).

An ungrouped sketch feature turns into two single polygon 
features that are both selected.
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The Regroup tool      is enabled when a standard feature is ungrouped.  An ungrouped standard feature must be 
regrouped before another feature may be selected.  When the Regroup tool is clicked the feature is reassembled after 
which other edit operations such as selecting other features and saving or undoing edits become available.

The Group tool      is enabled when more than one sketch feature is selected.  When the Group tool is clicked, the 
graphics from all the selected features are added to the first feature and all but the first feature are deleted.  

Polygons may be nested when being grouped or regrouped when:

The Group/Regroup Tool

When selecting features to be grouped, use 
the shift key and select the features one at a 
time.  The attributes for the first feature 
selected are retained after grouping.  

Encompass > Editing > Tools > Group/Regroup

Nested polygons 
after grouping.

Stacked polygons 
after grouping.

• there are more than one polygon in the feature being regrouped or more than one polygon in the 
selected features being grouped,

• at least one polygon is contained by another, and

• the feature class allows multi-loop polygons.

If these conditions are met, a dialog is displayed to offer a choice in how the polygons are combined.  Click Yes to nest 
the polygons.  In this case, an inside loop creates a hole in the polygon.  Click No to stack the polygons without 
creating holes.
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The Symbol Tool
Symbol creates point features in the current feature class.  When the Symbol button is 
clicked, a symbol representing new point feature is attached to the pointer at the 
symbol insertion point and dragged until a drop position is specified.  The drop position 
is indicated by a click on the map, a snap, or a precise location using Adjust Position.  
All snap methods are available except Nearest Tangent Point and Perpendicular To 
Line.

When a standard feature is created, if there are required attribute values and default 
values for them are not defined, the Edit Attributes dialog is displayed.  If this dialog is 
canceled or all of the required values are not entered, the feature is not added.

Depending on the feature class, a point feature may be free standing (like a survey 
control point), a node in a network (like a manhole), or a tap in a network (like a 
service connection on a main pipe).  If the new point feature represents a node or a 
tap and no suitable link is within the snap tolerance of the new position, a dialog is 
displayed.  Click Yes to add the feature even though there is no link nearby, or No to 
cancel the edit.  Node features are only allowed at the end of links.  Taps must be on a 
link but are not allowed at the link ends.

The symbol for a standard point feature is pre-defined.  The symbol for a sketch 
feature is defined on a feature-by-feature basis at the time the point feature is created.

A symbol is a graphic 
representation of a point 
feature.

Set default attribute values to 
speed up entry of multiple 
point features.

Use the escape to cancel an 
unfinished add change the 
current tool to Select.

Encompass > Editing > Tools > Symbol

Insertion point for 
the default symbol 

Nodes must be at the end of a link.
Taps must be along a link.
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The Line Tool
Line creates line features in the current feature class.  The first click or snap on the 
map starts the line input.  Subsequent clicks add vertexes.  If Allow Curves is 
checked, an arc shape point is placed at the mouse up position when the mouse button 
is held down instead of clicked. 

There are four line construction methods:

Encompass > Editing > Tools > Line

Freeform Lines creates multi-segment lines using a series of input positions.  

Two-Point Lines creates a single segment line using two click or a press-slide-release 
action.

Orthogonal Lines is like freeform lines but always creates lines that are horizontal or 
vertical to the map window edges regardless of the map view rotation.

Traverse displays a spreadsheet-like grid for defining line using coordinate geometry 
(a.k.a. COGO).

Nearest Tangent Point and Perpendicular To Line snaps are available after the first 
vertex is defined.
To complete the line input, either double-click on the map, press the enter key, or click 
Close Line or End Input on the popup menu.

Depending on the feature class, a line feature may be free standing (like a curb edge), 
or a link in a network (like a water main pipe).  If the new line feature represents a link 
and no suitable node is within the snap tolerance of the new position, a dialog is 
displayed.  Click Yes to add the feature even though there is no node nearby, or No to 
cancel the edit.
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1st click

mouse down 
defines arc 
shape point

mouse up 
completes the arc

Line features may be 
closed, but they do not 
form polygons.

To draw a multi-segment 
line with a precisely 
defined curve in it, draw a 
straight line between the 
ends of the arc and use 
the Shape tool to set the 
radius of the arc segment

Use freeform lines with 
Allow Curves to draw 
clouds.

Freeform line construction 
with Allow Curves turned on 
using a press-slide-release 
action.

Freeform line construction with 
multiple sequential clicks.

mouse down 
defines start 
point

mouse up 
defines end 
point

Two-Point line construction 
using a press-slide-release 
action.  If Allow Curves is 
on, this draw an arc.

first click 
defines start 
point

second click 
defines end 
point

Two-Point line construction 
using two clicks.  If Allow 
Curves is on, use a press- 
slide-release on the second 
click to create an arc.

1st click

2nd click

3rd click

4th click
5th click

Orthogonal line construction 
with multiple sequential clicks.

The Line Tool - Construction Methods
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The Line Tool - Traverse

Encompass > Editing > Tools > Line > Traverse

The Line Traverse tool constructs a line or polygon features based on coordinate geometry entered into a spreadsheet- 
like grid.  Each row in the grid represents a single segment (a.k.a. course) in the traverse.  Leaving a row in the grid 
either by using the arrow keys or clicking on another row causes the geometry for that row to be calculated (or 
recalculated) which then adjusts all the subsequent rows in the traverse accordingly.

The entire traverse can be rotated by setting the angle in Bearing Rotation Adjustment.  If this is a non-zero value, the 
traverse is rotated in a counter-clockwise direction around the first vertex in the traverse. 

Traverse closure information is described in Closure Status.  The Traverse tool does not perform closure adjustments 
(like root-mean-square). 

A click on the map adds a coordinate 
to the traverse grid.  If the grid is 
empty, the click on the map is the 
start position of the traverse and the 
coordinates are entered into the first 
From X and From Y.  If there is at 
least one row defined in the grid, a 
click on the map adds a row.

See The Traverse Tool – Defining 
Geometry for details on entering 
coordinate geometry using the grid.

The OK button ends the input, closes 
the dialog, and saves the new line to 
the database, the Cancel button 
closes the dialog and discards the 
line.
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The Line Tool - Traverse Geometry

Encompass > Editing > Tools > Line > Traverse Geometry

The view rotation is added to the 
bearings entered in the Traverse 
Dialog.  Keep it simple by setting the 
view rotation to 0.

The traverse entry may not be 
interrupted with a pan or zoom.

Arrow keys move the input focus 
around the spreadsheet.  A carriage 
return behaves like a right-arrow key.

The closure bearing and distance 
may be copied using ctrl-c and then 
pasted into the bearing and distance 
cells.

From X and From Y contain the coordinates for the first vertex of the segment.

The value in the Curve column indicates that the row represents a straight 
segment or a circular arc that curves either to the left or right of the direction 
the traverse is drawn.  

Bearing indicates the bearing of a straight segment or the bearing of a tangent 
line at the starting point of a curved segment.  The Bearing Dir indicates the 
direction of the segment or arc reference line relative to the value in Bearing.  
For straight segments the possible values are “forward”, “reverse”, “90° right”, 
and “90° left”.  For curved segments, the possible values are “tangent”, “back 
tangent”, ”radial to center”, and “radial from center”.

The length of a straight segment is set in the Length column.  This value is 
calculated for curved segments and is not editable.  Curve geometry is defined 
in the Radius and Delta Angle columns.

forward 
bearing

reverse 
bearing

right 
bearing

left 
bearing

tangent 
bearing

back tangent 
bearing

radial to center 
bearing

radial from center 
bearing

curve 
right

curve 
left

curve 
right

curve 
left

curve 
right

curve 
left

curve 
right

curve 
left
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The Arc Tool

Arc creates curved single segment line features in the current feature class.  The first 
click or snap on the map starts the arc input, the second position defines a point along 
the arc, and the third position defines the arc end.  The curve of the arc appears after 
the second position is defined.
Nearest Tangent Point and Perpendicular To Line snaps are available after the first 
vertex is defined.

There is no toolbar popup menu for Arc.

Arc is useful for rapidly 
drawing arced leader lines.

Use a Perpendicular to Line 
snap on the third position to 
create a quarter circle.

Encompass > Editing > Tools > Arc

1st click

2nd click

3rd click

3-point arc 
construction.
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The Rectangle Tool

When using Adjust 
Position, use a negative X 
value to draw the rectangle 
to the left and a negative Y 
value to draw the rectangle 
downward.  

Encompass > Editing > Tools > Rectangle

Rectangle creates rectangular polygon features in the current feature class.  The first 
click or snap on the map defines one corner of the rectangle and the second position 
defines the diagonally opposite corner.  The first position may be on any of the four 
corners.
Nearest Tangent Point and Perpendicular To Line snaps are only available for the 
second position.
The rectangle is always drawn orthogonal to the map window.  To draw a rotated 
rectangle, first rotate the view.
Use Adjust Position on the second vertex to define a rectangle with a specific width 
and height.

There is no toolbar popup menu for Rectangle.

Drag from the mouse- 
down position to the 
mouse-up position.

Click or snap on the “first 
corner” position and then 
on the “opposite corner” 
position.

mouse 
down

mouse 
up

2nd click

1st click

Click or snap on the “first 
corner” position and then 
use Adjust Position to 
specify the rectangle size.

1st click

adjusted 
position
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The Circle Tool

Circle creates polygon features in the current feature class.  Unless the construction 
method is Center and Radius, the first click or snap on the map starts the circle input.  
Subsequent clicks define points on the circle’s circumference

There are four circle construction methods:

Encompass > Editing > Tools > Circle

Center and Radius creates a circle of a specified 
radius at the first (and only) clicked position.  Use Set 
Radius to specify the radius for the circle.

Nearest Tangent Point and Perpendicular To Line snaps are available after the first 
position is defined.
A press-slide-release action may be used on the Center and Position and Two 
Positions methods.

Center and Position locates the circle center at the first position and a point on the 
circle circumference at the second position. The circle radius is the distance between 
the two positions.

Two Positions creates a circle from two diametrically opposed positions.  The circle 
radius is half the distance between the two positions

Three Positions creates a circle from three positions on the circle circumference.
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1st click

Center and Radius 
construction.  The radius 
must be set before the circle 
is created.

Center and Position construction 
using a press-slide-release action.

Three Positions construction.Two Positions construction.
Use Adjust Position to 
create precisely defined 
circles as an alternate to 
Center and Radius.

mouse 
up

mouse 
down

1st click

2nd click 3rd click
2nd click

1st click

The Circle Tool – Construction Methods
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The Polygon Tool

Encompass > Editing > Tools > Polygon

Polygon creates polygon features in the current feature class.  The first click or snap on 
the map starts the polygon input.  Subsequent clicks add vertexes.  If Allow Curves is 
checked, an arc shape point is placed at the mouse up position when the mouse button 
is held down instead of clicked. 

There are two polygon construction methods:
Freeform Lines creates multi-segment polygons using a series of input positions.  

Traverse displays a spreadsheet-like grid for defining line using coordinate geometry 
(a.k.a. COGO).  For more detail on using the Traverse method, see the Line tool.

Nearest Tangent Point and Perpendicular To Line snaps are available after the first 
vertex is defined.
To complete the line input, either double-click on the map, press the enter key, or click 
End Input on the popup menu.  End Input is available once three vertexes have been 
defined.
Use Adjust Position to position vertexes precisely relative to the last vertex or at a 
specific coordinate.
While constructing polygons, the closing segment is drawn automatically.

Freeform polygon construction 
with multiple sequential clicks.

1st click

2nd click
3rd click

4th click
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The Text Tool

To add text at an angle, 
rotate the view before 
starting the Text tool.

Encompass > Editing > Tools > Text

Text creates text features in the current feature class.  A click on the toolbar or map 
displays the Enter New Text window.  To create multi-line text, use an underscore 
character or a carriage return             between lines.  When an underscore character is 
used, the line breaks do not show in the Enter New Text window.

Set the new text justification by clicking on one of the nine points in the justification part 
of the Enter New Text window.  See the Edit Justification tool for more.

Click OK to attach the new text feature to the pointer at its justification point and drag it 
until a drop position is specified.  To precisely locate the new feature use a right-click 
with a snap method or Adjust Position. All snap methods are available except 
Nearest Tangent Point and Perpendicular To Line.

After the new text feature is added, the Enter New Text window displays again so 
another new text feature may be added.  To discontinue text entry, click Cancel or 
press the escape key.

There is no toolbar popup menu for Text

See the Annotation tool for adding annotation and data annotation primitives to features.

enter

text content
text justification
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The Text Tool – Text Along a Line

Use top-center, center- 
center, or bottom-center 
justification for the best 
spacing when placing text 
along a line.

Encompass > Editing > Tools > Text > Text Along a Line

After entering the new text content and clicking the OK button on the Enter New Text 
window, use a right-click on the map to display the popup menu and click Fit Text To 
Line to distribute the text content along an existing line or polygon boundary.  

The right click that popped up the menu also defines the position of the first character.  
The second click on the line defines the position of the last character.  The other 
characters are then evenly spaced between the first and last with each character 
justification point located on the line.

Cam
pa

an
Drvei

Cam
paan

Drive

Campana Drive Cam
pa

an
D r i v e

2nd click 
on line

right- click 
near line  to 
pop up menu

mouse 
movemouse 

move
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The Annotation Tool

Annotation and data annotation primitives that may be embedded into features that 
contain at least one point, line, polygon, or text primitive.  Data annotation displays one 
or more values from database fields and may be mixed with literal text.  Annotation only 
contains literal text.

Annotation is displayed on the map by checking Show Entry’s Annotation on the 
popup menu for the legend in the Map Contents window. 

The Annotation tool is only available when single feature is selected. 

Use horizontal stacking for 
annotating lines and vertical 
stacking for points and 
polygons.

Encompass > Editing > Tools > Annotation

27
’ 4”

ABS Ja
n 2

00
6 

27’ 4” ABS Jan 2006 

Dropping annotation 
off of the feature 
keeps it orthogonal.

Dropping annotation 
on the feature 
rotates it.

To configure the annotation, either right-click on the tool button 
or click Set Annotation Properties from the popup menu.  
Use the Stack and Locate options to orient the text, check 
database fields to include, and/or enter literal text into the text 
box.

As the new annotation is dragged into position, it automatically 
rotates it to align to the feature being annotated.  Holding the 
shift key down while dragging maintains the annotation 
rotation. 
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The Leader Tool

Add a leader after annotation 
is placed.  

Draw leaders from the 
annotation to the feature.

Use the Shape tool to make 
curved leaders.

Encompass > Editing > Tools > Leader

Leader primitives may be embedded into features that contain at least one point, line, 
polygon, or text primitive.  Leaders are typically used to graphically connect annotation 
to the feature being annotated when the annotation is not close enough to be 
unambiguously associated with the feature.  

Leaders, like annotation, are displayed on the map by checking Show Entry’s 
Annotation on the popup menu for the legend in the Map Contents window. 

The Leader tool is only available when single feature is selected. 
Nearest Tangent Point and Perpendicular To Line snaps are available after the first 
vertex is defined.
To complete the leader input, either double-click on the map, press the enter key, or 
click End Input on the popup menu.

27’ 4” ABS Jan 2006 

3rd 

click

2nd 

click
1st 
click
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The Luggage Tag Tool

Luggage tags combine text, data annotation, a enclosing polygon, and a leader in a 
single feature that annotates another feature.  For example, a luggage tag may be used 
to annotate a manhole, valve, or parcel.  Unlike annotation and leaders, luggage tags 
are not embedded into the feature they annotate. 

Control the fonts, fills, and 
line styles through Map 
Contents.

Use a line or point snap on 
the feature being annotated.

Luggage tag contents may 
be changed while it is being 
dragged by right-clicking on 
the map to display the popup 
menu, clicking on Set 
Annotation Properties, and 
altering the settings in the 
Annotation window.

Encompass > Editing > Tools > Luggage Tag 

1st click 
snap to line

27’ 4” ABS Jan 2006 

2nd click

1st click 
snap to line

27’
4”
ABS
Jan 2006 

2nd click

1st click 
snap to line

Length: 27’
Diameter: 4”
Material: ABS
Install Date: Jan 2006 

2nd click

Horizontal stacking.Vertical stacking with 
captions turned off.

Vertical stacking with 
captions turned on.

To configure the luggage tag, either right-click on the tool 
button or click Set Annotation Properties from the popup 
menu.  Use the Stack to orient the text either vertically or 
horizontally.

Use Turn Captions On or Turn Captions Off to include or 
exclude captions from the luggage tag.  Captions don’t show 
when luggage tag is oriented horizontally
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The Dimension Tool

Encompass > Editing > Tools > Dimension

Dimension creates a multi-primitive feature in the current feature class that dimensions 
another feature.  The dimension feature contains one text primitive located at the mid 
point of each segment plus one small circle located at every vertex of the dimensioned 
feature.

Once the Dimension tool is started, a click anywhere on a feature adds dimensions. No 
snaps are required.

Use Set Dimension Format to control how the dimension text is displayed:

Dimension 
Format

Source 
Number

Formatted 
Number

# 2.5 2

#.## 2.5 2.5

#.00 2.5 2.50

18.5’

21.4’

42.4’

33
.5

’

32.5’ 41.7’

30.8’

click 
anywhere 
on the line
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The Move Tool

Encompass > Editing > Tools > Move

Use the Move tool to reposition one or more features.  Once selected, features may be 
dragged or repositioned precisely.  When dragging, the mouse-down position must be 
on a selected feature.

To precisely move features use two clicks with snap methods or Adjust Position. All 
snap methods are available except Nearest Tangent Point and Perpendicular To 
Line.

If the mouse-down or first clicked position is not on a selected feature, a new feature 
selection at the clicked position is attempted.  The mouse-down or first clicked position 
attaches the selected feature to the pointer at the clicked position.

Drag from the mouse-down 
position to the mouse-up 
position.

Use a snap instead of a left 
click to pick up only one 
feature when there are 
several in close proximity.

1st click

2nd click

Click or snap on the “move 
from” position and then on 
the “move to” position.

After moving annotation in an ungrouped feature, a dialog is 
displayed when there are multiple annotation primitives.  
Click Yes to move all the annotation by the same distance 
and in the same direction.  

The Move tool re-selects. Right-click on the map to display the popup menu.
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The Copy Tool

Encompass > Editing > Tools > Copy

Use the Copy tool to copy a single feature.  The feature being copied is selected on the 
first mouse action.  It may be on any selectable layer in the view, including the current 
layer.  The selected feature is copied to the current layer at the position defined by the 
second mouse action. 

If the current layer does not allow the geometry type being copied, a warning message 
is displayed and the feature is not copied. 

To precisely copy features use two clicks with snap methods or Adjust Position. All 
snap methods are available except Nearest Tangent Point and  Perpendicular To 
Line.

The Copy tool re-selects. Right-click on the map to display the popup menu.

Drag from the mouse-down 
position on the feature being 
copied to the mouse-up 
position.

Use Edit > Copy and Edit > Paste 
to copy multiple features.  The 
features are pasted into the current 
layer.

1st click

2nd click

Click or snap on the “copy 
from” position and then on 
the “copy to” position.

To position the copied feature on 
top of the original, use Adjust 
Position with a relative X = 0 and 
Y = 0 position.
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The Rotate Tool

Encompass > Editing > Tools > Rotate

Drag from the mouse-down 
position to the mouse-up 
position.

Use a snap instead of a left 
click to pick up only one 
feature when there are 
several in close proximity.

1st click 3rd click

2nd click

Use the Rotate tool to rotate one or more features.  Once selected, features may be 
rotated either by dragging, with a series of three clicks, or by specifying a “rotate by” or 
“rotate to” angle.  When dragging, the mouse-down position must be on a selected feature.

To rotate features precisely about an anchor point, use three clicks with snap methods or 
Adjust Position. All snap methods are available except Nearest Tangent Point and 
Perpendicular To Line. 

To rotate features by a specific amount, use Rotate By….  
Enter a number between -360 and 360 to specify the 
rotation in degrees.  A positive angle rotates features 
counter-clockwise.  Features are rotated about the center 
of their extents.

Use Rotate To… to specifically set the rotation angle for 
point or text features.  A value of 0 un-rotates features.

The Rotate tool re-selects. Right-click on the map to display the popup menu.

Click or snap on the “anchor” position, 
then on the “rotate from” position, and 
finally on the “rotate to” position.
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The Scale Tool

Encompass > Editing > Tools > Scale

Use the Scale tool to resize one or more features.  Once selected, features may be 
resized either by dragging, with a series of three clicks, or by specifying a scale ratio.  
When dragging, the mouse-down position must be on a selected feature.

To scale features precisely about an anchor point, use three clicks with snap methods 
or Adjust Position. All snap methods are available except Nearest Tangent Point 
and Perpendicular To Line. 

To scale multiple features 
and not change their relative 
position, use Set Scale By 
Ratio.

Drag from the mouse- 
down position to the 
mouse-up position.

1st click

2nd click

3rd click

Click or snap on the 
“anchor” position, then on 
the “scale from” position, 
and finally on the “scale 
to” position.

To scale features by a specific amount, use Set Scale By 
Ratio.  Enter a number greater than 1 to make features 
larger or less than 1 to make them smaller.  Features are 
scaled about the center of their extents.

The Scale tool re-selects. Right-click on the map to display the popup menu.

Set Scale By Ratio 
resizes the feature 
around the extent 
center.
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The Delete Tool

Encompass > Editing > Tools > Delete

Use the Delete tool to remove one or more features from the database.  Delete 
operates on the selected set of features or on any feature that is clicked while 
the tool is current.

Use a snap instead of a left 
click to pick up only one 
feature when there are 
several in close proximity.

Related data records may also be deleted when they are exclusively 
associated with the deleted features.  For example, if a pipe is deleted and it 
has a related luggage tag, the luggage tag is also deleted. 

As with all other feature edits, the changes to the database are permanent after 
the File > Save Feature Edits menu is clicked.

The Delete tool re-selects. Right-click on the map to display the popup menu.

A warning message is 
displayed before any features 
are deleted.  Click OK to delete 
the features.
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The Extend Tool

Snap to the nearest line to 
extend the current line 
segment to the intersection 
point of the two lines.

Encompass > Editing > Tools > Extend

Use the Extend tool to shorten or lengthen a straight or curved line segment. The end 
of the segment that is extended is the closest end to the first mouse click or mouse 
down position.

To precisely set the length of a segment, use a snap method or Adjust Position with 
the second click. All snap methods are available except Nearest Tangent Point and 
Perpendicular To Line.

Use Extend Line By… to lengthen or shorten the 
selected segment by a specific amount.  A 
positive number lengthens the line by the 
specified amount, a negative number shortens the 
segment.

Use Set Line Length To... to set the segment to 
a specific length.

The Extend tool re-selects. Right-click on the map to display the popup menu.

Shorten line segment Lengthen line segment

1st click

2nd click 1st click

2nd click

Lengthen line segment 
in a polygon

1st click

2nd click
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The Shape Tool

When editing features with a 
lot of vertexes, to improve 
the display speed of the 
selected features, either 
zoom in so the entire feature 
is not displayed or uncheck 
Show All Shape Points.

To select multiple vertexes, 
hold the shift key down while 
clicking on vertexes.

Note how the pointer 
changes while the mouse 
moves over selected 
features.  The pointer symbol 
indicates the operation that 
will be performed when a 
click is made.

Encompass > Editing > Tools > Shape

Use the Shape tool to add, move, or delete one or more vertexes in a line or polygon 
features or to change the geometry type of a feature from a line to a polygon or a 
polygon to a line. 
When Show All Shape Points is checked, every vertex on the 
selected features is marked with a square and the mid-point of every 
segment is marked with a circle.  If it is unchecked, only the current 
vertex and its adjacent vertexes are marked.

When Show Vertex Numbers is checked, every vertex of the 
selected features are labeled with their sequence number.

Use Delete Vertex to remove clicked vertexes from the feature.

Use Move Vertex to change the position of selected vertexes, 
straighten curved segments or curve straight segments, and change 
the radius of curved segments.

Use Move Line to move the two vertexes at the end of the selected 
segment in one operation.

Use Move Path to insert vertexes at two clicked positions and move 
all the vertexes between the two clicked positions in one operation.

1

2 3

4
5 (end)
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The Shape Tool - Popup Menu
To precisely position a vertex, use a snap method or Adjust Position with the second 
click. All snap methods are available except Nearest Tangent Point and 
Perpendicular To Line.

Use Delete Vertex to remove the current vertex or vertexes.   Delete Vertex is enabled 
only when a right-click is made while the mouse is over a vertex.

Use Insert Vertex to add a vertex at the clicked position.  Insert vertex is enabled only 
when a right-click is made while the mouse is not over a vertex or the segment mid- 
point.

Remove Segment deletes the two vertexes at the ends of the clicked segment.  

If the clicked segment is curved, use Straighten Line to turn the curved segment into a 
straight segment.  Straighten Line is enabled only when a right-click is made while the 
mouse is over curved segment.

Encompass > Editing > Tools > Shape > Popup Menu

If a right-click is made while the mouse is over curved 
segment, Set Curve Radius may be used to precisely 
define the curve’s radius.  The radius can not be less 
than half the straight-line distance between the two 
segment ends.  The segment’s current radius is 
displayed as a default value.  If the curved segment is 
part of a circle, Set Circle Radius is available.
Geometry types may be changed depending on the geometry type of the selected 
feature.  Use Convert to Line to change the selected geometry from a polygon or a 
leader to a line, use Convert to Leader to change a line to a leader, or use Convert to 
Polygon to change a line to a polygon.

The Shape tool re-selects. Right-click on the map to display the popup menu.
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The Shape Tool - Pointers
The mouse pointer used by the Shape tool changes as it is moved around the map to indicate 
the action that will be taken when the mouse button is clicked.

Encompass > Editing > Tools > Shape > Pointers

Select Vertex:  the mouse is not over a selected feature.  If a click is made, a re-select is 
attempted and if successful, an action appropriate to the part of the geometry that was clicked 
is started.  For example, if a re-select is made at the end of a line feature, a vertex move 
action is started.

Move Vertex:  the mouse is over a vertex on a selected feature. A click attaches the vertex to 
the mouse so it may be moved into a new position.

Change Curve:  the mouse is over the mid-point of a segment on a selected feature.  A click 
attaches a curve point to the mouse.  When the mouse is moved, a new three-point curve is 
drawn that is fixed at the segment ends and passes through the curve point.  

Insert Vertex:  the mouse is over a selected feature but is not on a vertex or mid-point.  A click 
adds a vertex at the clicked position and attaches the new vertex to the mouse so it may be 
moved. 

Delete Vertex:  the mouse is over a vertex on a selected feature.  A click removes the vertex 
from the feature.  This pointer is only displayed while the Delete Vertex method is active.

Move Line:  the mouse is over a selected feature but not at a vertex.  A click selects the 
segment’s two vertexes and attached the segment to the mouse so it may be moved into a 
new position. This pointer is only displayed while the Move Line method is active.

Move Path:  the mouse is over a selected feature but not at a vertex.  The first click defines 
the path start position and inserts vertexes as required, the second click defines the path end 
position, inserts vertexes as required, and attaches the path to the mouse so it may be moved 
into a new position.  This pointer is only displayed while the Move Path method is active.

To insert a vertex 
without also moving 
it, use Insert Vertex 
on the popup menu.

Selected vertexes 
are marked with  
black dots:
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The Reverse Tool

The reverse action is applied 
immediately when clicking on 
features while the Reverse 
tool is active.

Encompass > Editing > Tools > Reverse

Click anywhere on a 
selected feature to reverse 
the vertex order.

Use the Reverse tool to reverse the vertex order on one or more features.  If there are 
selected features when the Reverse tool is started, their vertex order is immediately 
reversed.  The vertex reverse action is also taken when a feature is selected while the 
Reverse tool is current.

Arrows drawn at the mid-point of each segment indicate the direction the line geometry 
is drawn (from the lowest vertex number to the highest).

There are no snap methods available for Reverse.

The Reverse tool re-selects.  Right-click on the map to display the popup menu.

vertex 1

vertex 2

vertex 3

vertex 4
vertex 5

vertex 5

vertex 4

vertex 3

vertex 2
vertex 1
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The Fillet Tool
Use the Fillet tool to add a fillet of a specified radius at any vertex along a multi-segment 
line except the line end points.  

To add a fillet between two 
features, first use the Join 
Line tool to connect the 
features at the fillet point.

Encompass > Editing > Tools > Fillet

click near a vertex to 
insert a fillet

There are no snap methods available to the Fillet tool.  A point snap is implicit 
when a left-click occurs near a suitable vertex.

The Fillet tool re-selects.  Right-click on the map to display the popup menu.

Fillets may not be added at 
line ends or at vertexes 
where the adjacent 
segments are too short.

The fillet radius may not be greater than the segment 
lengths between which the fillet is located.  If the fillet 
does not fit at the clicked vertex, a warning message is 
displayed.

To set the fillet radius, either right-click on the fillet tool 
button or select Set Fillet Radius from the popup menu.   
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To create multi-line text, use an underscore 
character or a carriage return             between lines.  
When an underscore character is used, the line 
breaks do not show in the Edit Text window. 

To edit data annotation, the feature must first be 
ungrouped.  Text and annotation primitives may be 
edited whether or not the feature is ungrouped.  The 
Edit Text window caption differentiates between 
text, annotation, and data annotation.  When editing 
data annotation, a list of annotatable database fields 
is displayed.  Click on a field name to add it to the 
text content.

Data annotation text may be a combination of text 
that is displayed literally and references to database 
fields in the feature’s record.  To distinguish column 
name from literal text, bracket the column name with 
curly braces.  

The Edit Text Tool

Text wraps in the Edit Text 
window, so to distinguish 
between wrapping text and 
multi-line text when the text 
content is long, widen the 
window by dragging the right 
edge.

Encompass > Editing > Tools > Edit Text

Use the Edit Text tool to alter text content in existing text, annotation, and data 
annotation.  To edit multiple features, select them before starting the Edit Text tool.  If 
the selected features do not contain editable text, a message is displayed.  If multiple 
features are selected before starting the Edit Text tool, the text content from the last 
feature clicked is used as a default when the Edit Text window is displayed. 

enter

There are no snap methods available to the Edit Text tool.  A text snap is implicit 
when a left-click occurs near a suitable text primitive.

The Edit Text tool re-selects.  Right-click on the map to display the popup menu.
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The Edit Justification Tool

When text is placed near a 
point feature, set the 
justification to be closest to 
the point feature.

When text is placed along a 
line feature, set the 
justification to be top or 
bottom and position it on the 
line feature.

When text is placed inside a 
polygon feature, set the 
justification to the center.

Encompass > Editing > Tools > Edit Justification

Use the Edit Justification tool to change the 
justification point of text primitives. To edit 
multiple features, select them before starting 
the Edit Justification tool.  If the selected 
features do not contain text, a message is 
displayed.  

If multiple features are selected before 
starting the Edit Justification tool, the 
justification from the last feature clicked is 
used as a default when the Edit Justification 
window is displayed. 

The position of the text relative to its anchor 
point changes when the justification is 
changed. 

When text size is changed, the justification 
point remains in the same position.  This 
has the effect of sizing around the 
justification point.

There are no snap methods available to the 
Edit Justification tool.  A text snap is implicit 
when a left-click occurs near a suitable text 
primitive.

The Edit Justification tool re-selects.  Right- 
click on the map to display the popup menu.
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Use the Graduate tool to create a series of perpendicular lines (a.k.a. tickmarks) that 
are spaced a specific distance along another feature (a.k.a. the reference line).  Each 
tickmark is a two-vertex straight line and is always oriented perpendicularly to the 
reference line.  The Graduate tool creates a multi-primitive feature in the current feature 
class.

The Graduate Tool

When using a Nearest 
Intersection snap where 
there are two features that 
cross, the feature that is 
drawn on top is used as the 
reference feature.

Encompass > Editing > Tools > Graduate

2nd click 
on line
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nTo start the graduation, click on a line feature or polygon 
boundary.  As the mouse is moved along the line, tick marks 
appear as the mouse moves the specified distance away 
from the previous tickmark.  The second click or a carriage 
return             finalizes the tickmark positions. A tick mark is 
not drawn at the start click point.

To set the graduation spacing and the tick mark length, 
either right-click on the tool button or click Set Tick 
Properties from the popup menu.
To start a graduation at a precise location or relative to the last clicked position, use 
Adjust Position with the second click.

Only Nearest Point, Line, Mid Point, End Point, and Intersection snap methods are 
available.

enter
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To start a division at a precise location or relative to the last clicked position, use Adjust 
Position with the second click.

Only Nearest Point, Line, Mid Point, End Point, and Intersection snap methods are 
available.

The Divide Tool

Encompass > Editing > Tools > Divide
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Use the Divide tool to create a series of perpendicular lines (a.k.a. tickmarks) that 
evenly divides the length between two clicked positions along another feature (a.k.a. the 
reference line).  Each tickmark is a two-vertex straight line and is always oriented 
perpendicularly to the reference line.  The Divide tool creates a multi-primitive feature in 
the current feature class.

To start the division, click on a line feature or polygon 
boundary.  As the mouse is moved along the line, the tick 
marks spread out to evenly to divide the space between the fist 
click and the mouse position.  A second click or a carriage 
return             finalizes the tickmark positions.  Tick marks are 
not drawn at the start or end click positions.  

To set the number of divisions and the tick mark length, either 
right-click on the tool button or click Set Tick Properties from 
the popup menu.  The number of tickmarks drawn is always 
one less than the value specified in Number of Divisions.

enter

When using a Nearest 
Intersection snap where 
there are two features that 
cross, the feature that is 
drawn on top is used as the 
reference feature.
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Click one of the Feature-to-Feature Jump 
Mode options specify how the traced line 
behaves when jumping from one feature to 
another.

To complete the trace line input, use End 
Input or a carriage return            , or to join 
the ends of the trace line to form a polygon, 
use Close Line.  

The Trace Tool

When tracing around a 
polygon, the shortest 
path is take.  To force a 
specific direction, use 
several intermediate 
clicks.

Encompass > Editing > Tools > Trace

1st click 
on line

mouse 
move

2nd click 
on line

Use the Trace tool to create a line that lies along or is offset a 
specific distance from one or more features (a.k.a. the reference 
features).  New trace lines are created in the current feature class. 

To set the trace offset distance and the feature jump mode, either 
right-click on the tool button or click Set Trace Properties from the 
popup menu.  

An Offset Distance of 0 traces directly on top of the reference 
features.  A positive distance offsets the traced line to the left of the 
reference features relative to the direction the line is being drawn.  A 
negative value offsets the traced line to the right.

Intersection Point

1st

2nd

Last Clicked Position

2nd

1st

3rd

Closest Vertex

2nd

1st

Closest Position

2nd

1st

enter

Only Nearest Point, Line, Mid Point, End Point, and 
Intersection snap methods are available.
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The Buffer Tool

Buffers are polygons – if the 
polygon style is set to be 
filled, the new buffer will 
mask the reference feature.

Encompass > Editing > Tools > Buffer

A buffer is the region that is a specified distance around a feature.  Use the Buffer tool 
to create buffer polygons around a point, line, or polygon feature (a.k.a. the reference 
feature).  A distance measured perpendicularly form any point on a reference feature 
to the buffer polygon boundary always equals the buffer distance.

Once the Buffer tool is started, a click anywhere on a feature adds a buffer polygon 
using the specified buffer distance in the current feature class.  No snaps are required.

To set the buffer distance, either right-click on the tool button or click Set Buffer 
Distance from the popup menu.  

Buffer on a 
point feature.

Buffer on a 
line feature.

Buffer on a 
polygon feature.
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If there are multiple line features selected when the Join Line tool 
is started, a dialog is displayed.  Click Yes to join or intersect the 
selected lines into one continuous feature.  

There are three Join Line methods:

The Join Line Tool

When selecting a line to join, 
click near a line end, not at 
an end or in the middle.    

Encompass > Editing > Tools > Join Line

Use the Join Line tool to connect two or more line features into one.  When two line 
features are joined, the attributes on the line feature that is selected first are retained.  
The entire record for the second line feature is deleted after the join is made.  The two 
features must be in the same feature class to be eligible for joining.  

Join Two Ends with Straight Line joins the clicked ends with a straight line.    

Intersect Two Ends extends the two clicked ends to their intersection point.

Assemble into Polygon forms a polygon from the selected lines.  This is only 
available if all the selected lines have coincident ends. 
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click
2nd 

click
Intersect close ends.

1st 

click

2nd 

click

Join  far end and close end.

1st 

click
2nd 

click
Join close ends.

1st 

click
2nd 

click
Join far ends.

Intersect multiple features.

Join multiple features.
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The Split Line Tool

Encompass > Editing > Tools > Split Line

Use the Split Line tool to break a line feature into two or more features.  Features 
created from the split are created in the same feature class as the feature being split.  
All attribute values are copied from the source feature to the new features.

There are four Split Line methods:

Explode Line Segments

1
2

3
4

1

2

Delete Line Segment

1

2

Delete Path

1

2

Split Line

Split Line breaks a feature at the clicked 
position.  Positions at the first and last vertex of 
a line are invalid.

Delete Path breaks a feature at the first clicked 
position and starts the new second feature at 
the second position.  This has the effect of 
creating a gap between the two positions.

Delete Line Segment breaks a feature at the 
beginning of the clicked segment and starts the 
new second feature at the end of the clicked 
segment.  This has the effect of creating a gap 
by removing the entire segment.

Explode Line Segments breaks a feature at 
every vertex creating single segment features. 

Except for Explode Line Segments, the new 
feature is selected at the end of the operation.  After 
an explode, all the single segment features are 
selected. 
Only Nearest Point, Line, Mid Point, End Point, and Intersection snap methods 
are available.
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The Join Polygon Tool

To join two polygons that do 
not overlap or share a 
boundary, create a third 
polygon that overlaps both 
and join to it first.

Encompass > Editing > Tools > Join Polygon

Click on an adjacent 
polygon to join it to the 
selected polygon.

The selected polygon is 
altered.  The second 
polygon is unaltered.

Use the Join Polygon tool to modify a selected polygon by merging it with adjacent or 
overlapping polygons.  Any polygon in a selectable feature class that is adjacent to the 
selected polygon is eligible for joining.  The features that contain the polygons that are 
merged are not altered.

The Join Polygon tool is only available if a single feature that contains a polygon is 
selected.   

To join polygons, first, using the Select tool, select a single feature that contains a 
polygon.  This is the feature that will be modified.  Next, click on an adjacent polygon.  
If it is on a selectable layer and either shares a boundary 
with the original polygon or overlaps it, the two polygons 
are merged, modifying only the original feature.  If there 
is no connection between the polygons, a warning 
message is displayed.
Although point and line snaps are available, a left-click is sufficient to identify polygons 
to be joined. 
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